算法日记(3) —— PAT Ranking

【PAT A1025】PAT Ranking

题目描述

1
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

输入格式

1
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

输出格式

1
2
3
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

输入样例

1
2
3
4
5
6
7
8
9
10
11
12
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

输出样例

1
2
3
4
5
6
7
8
9
10
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

参考代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Student {
char id[15]; //准考证号
int score; //分数
int location_number; //考场号
int local_rank; //考场内排名
}stu[30010];
bool cmp(Student a, Student b) {
if(a.score != b.score) return a.score > b.score; //先按分数从高到低排序
else return strcmp(a.id, b.id) < 0; //分数相同时按准考证号从小到大排序
}
int main() {
int n, k, num = 0; //num为总考生人数,n为考场数,k为对应考场的考生人数
scanf("%d", &n);
for(int i = 1; i <= n; i++) {
scanf("%d", &k);
for(int j = 0; j < k; j++) {
scanf("%s %d", &stu[num].id, &stu[num].score);
stu[num].location_number = i; //该考生的考场号为i
num++; //总考生加1
}
sort(stu + num - k, stu + num, cmp); //对该考场的考生进行排序
stu[num - k].local_rank = 1; //该考场经排序后的第一名考生的考场内排名记为1
for(int j = num - k + 1; j < num; j++) { //对该考场内剩余的考生的考场内排名进行赋值
if(stu[j].score == stu[j - 1].score) { //若与前一位考生分数相同,则考场内排名也相同
stu[j].local_rank = stu[j - 1].local_rank;
} else { //若与前一位考生分数不同,则考场内排名等于该考生的下标加1后减去之前考场的所有考生人数
stu[j].local_rank = j + 1 - (num - k);
}
}
}
printf("%d\n", num);
sort(stu, stu + num, cmp); //对所有考生进行排序
int r = 1;
for(int i = 0; i < num; i++) {
if(i > 0 && stu[i].score != stu[i - 1].score) {
r = i + 1; //若当前考生与前一个考生分数不同时,则排名为下标加1
}
printf("%s ", stu[i].id);
printf("%d %d %d\n", r, stu[i].location_number, stu[i].local_rank);
}
return 0;
}
-------------本文已经结束 ~\(≧▽≦)/~ 感谢您的阅读-------------